Задать вопрос
11 мая, 17:51

Составить программу в Паскале

Составить программу, чтобы компьютер запросил имя пользователя и

его год рождения, затем подсчитал

количество лет, дней и минут, прожитых, примерно, этим человеком. Результаты вывести

на экран.

+5
Ответы (1)
  1. 11 мая, 18:06
    0
    Type ye=1850 ... 2100;

    var year, year1:ye;

    name:string;

    a:integer;

    begin

    writeln ('Какой сейчас год?') ;

    readln (year) ;

    writeln ('Твое имя?') ;

    readln (name) ;

    writeln ('В каком году ты родился (родилась) ?') ;

    readln (year1) ;

    a:=year-year1;

    writeln ('Твое имя ', name) ;

    writeln ('Ты прожил ', a, ' Лет (года) ') ;

    writeln ('Ты прожил приблизительно ', a*365, ' дней') ;

    writeln ('Ты прожил приблизительно ', a*364*24, ' часов') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Паскале Составить программу, чтобы компьютер запросил имя пользователя и его год рождения, затем подсчитал количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу на паскале, чтобы ПК запросил имя пользователя и его год рождения, подсчитал возраст человека, в зависимости от возраста разработайте вариант диалога с пользователем (-ещё не учишься?; -учишься где?; уже не учишься?)
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1) Разработайте программу, запрашивающую у пользователя длины обеих катетов прямоугольного треугольника, и выводящую на экран гипотезу по формуле Пифагора 2) Запросите у пользователя длину ребра куба, Найдите и выведите на экран площадь одной грани,
Ответы (1)