Задать вопрос
5 августа, 17:43

Вычислить сумму квадратов цифр.

В Паскале

+3
Ответы (1)
  1. 5 августа, 20:59
    0
    Var I, S: integer;

    Begin

    S:=0;

    for I:=0 to 9 do {цикл, перебираем цифры от 0 до 9 и присваиваем их переменной I }

    S:=S+sqr (I) ; {sqr (I) - квадрат I, Вычисляем квадрат и добавляем его в } общую сумму S}

    writeln ('сумма квадратов цифр = ', S) ; {выводим сумму}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму квадратов цифр. В Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Программа в Pascal ABC: Дано натуральное число. Определить: а) количество цифр в нем; б) сумму его цифр; б) сумму квадратов его цифр.
Ответы (1)
Вычислить X=m / (n-m), где m - сумма квадратов отрицательных элементов первого вектора, n - сумма квадратов отрицательных элементов второго вектора в паскале
Ответы (1)
Введите в Паскале 5 чисел. Найдите сумму их квадратов и произведение квадратов этих чисел
Ответы (2)