Задать вопрос
7 марта, 14:31

Определить два наибольших числа в последовательности и найти их частное.

Не через массивы. Паскаль.

+2
Ответы (1)
  1. 7 марта, 14:47
    0
    Var

    max, prev_max, n: integer;

    begin

    max : = - 10000;

    prev_max : = - 10000;

    repeat

    read (n) ;

    if n > max then begin

    prev_max : = max;

    max : = n;

    end;

    until n = 0;

    writeln (max, ' ', prev_max, ' ', prev_max / max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить два наибольших числа в последовательности и найти их частное. Не через массивы. Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите с информатикой, ту массивы на языке Паскаль. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените нулем элементы массива, которые больше введенного с клавиатуры числа N. Выведите на экран исходный и полученный массивы
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Паскаль 1. Дано натуральное число N и N целых чисел, задаваемых пользователем. Определить, сколько среди этих N чисел двузначных. Массивы не использовать. 2. Дано натуральное число N и N целых трехзначных чисел, задаваемых пользователем.
Ответы (1)