Задать вопрос
8 апреля, 07:09

Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле (i+5) ^2). Параметр n должен задавать пользователь. Напишите программу, вычисляющую сумму значений элементов одномерного массива и среднее арифметическое введенных n чисел. Вывод оформите в строку через пробел.

+2
Ответы (2)
  1. 8 апреля, 08:33
    0
    Uses crt;

    const m=1000;

    var a:array[1 ... m] of integer;

    i, s, n:integer;

    sr:real;

    begin

    readln (n) ;

    writeln;

    s:=0;

    for i:=1 to n do

    begin

    a[i]: = (i+5) * (i+5) ;

    writeln (a[i]) ;

    s:=s+a[i];

    end;

    writeln;

    sr:=s/n;

    writeln (s,' ', sr) ;

    end.
  2. 8 апреля, 10:22
    0
    Var

    a: array[1 ... 100] of integer;

    i, s, n: integer;

    begin

    readln (n) ;

    for i : = 1 to n do begin

    a[i] : = (i + 5) * (i + 5) ;

    write (a[i],' ') ;

    s : = s + a[i];

    end;

    writeln;

    writeln (s, ' ', s / n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле (i+5) ^2). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сформируйте одномерный массив из 4 элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле i^2). Вычислить сумму значений элементов одномерного массива.
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)