Задать вопрос
18 октября, 05:34

Pascal ABC. Задан радиус окружности r. если радиус окружности меньше 6 см, найти длину этой окружности, в противном случае найти площадь круга, ограниченного данной окружностью. L=2pr, S=2pr^2

+2
Ответы (1)
  1. 18 октября, 09:20
    0
    Var

    r: real;

    begin

    writeln ('Введите радиус окружности в сантиметрах') ;

    readln (r) ;

    if r < 6 then writeln ('Длина окружности: ', 2 * pi * r)

    else writeln ('Площадь круга, ограниченного данной окружностью: ', pi * sqr (r)) ;

    end.

    Площадь круга равна pi * r^2, а не 2pr^2, как написано в условии!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC. Задан радиус окружности r. если радиус окружности меньше 6 см, найти длину этой окружности, в противном случае найти площадь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу через Pascal ABC. Дана длина L окружности. Найти ее радиус R и площадь S круга, ограниченного этой окружностью, учитывая, что L = 2*Pi*R, S = Pi*R2 (R в квадрате). Pi = 3.14 P. S Напишите полную программу
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Задачи в Paskal ABC 1. Дан радиус окружности. Вычислить длину окружности и площадь круга, ограниченного этой окружностью. 2. Даны 2 положительных числа. Вычислить их среднее арифметическое и среднее геометрическое.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Дана длина L окружности. Найти ее радиус R и площадь S круга, ограниченного этой окружностью, учитывая, что L = 2*Pi*R, S = Pi*R2. В качестве значения Pi использовать 3.14. В паскале, код нужен к задаче.
Ответы (1)