Задать вопрос
26 мая, 03:01

Помогите с задачей!

напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора (целое количество минут) - 3 День недели (1-понедельник, ... 7-воскресенье) - - 5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб. (она большая должна быть и для паскаля) !

+1
Ответы (1)
  1. 26 мая, 04:17
    0
    Program D1KPxx3;

    uses crt;

    var

    i:integer;

    min, rez:real;

    b:char;

    label 1,2;

    begin

    1:write ('Введите время разговора') ;

    read (min) ;

    writeln ('Введите номер дня недели') ;

    read (i) ;

    if (i=6) or (i=7) then

    begin

    rez: = ((min*5.52) - (min*0.2)) ;

    write ('Стоимость разговора с учетом скидки равна: ', rez) ;

    goto 2;

    end

    else

    rez:=min*5.52;

    write ('Стоимость разговора равна: ', rez) ;

    2:writeln ('Ещё? Y/N') ;

    readln (b) ;

    if b='Y' then

    goto 1;

    if b='N' then

    write ('Пока!') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с задачей! напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой по субботам и воскресеньям. Входные данные: Sm (стоимость минуты разговора), M (число минут), Day (день недели - 1 ... 7).
Ответы (1)
Программа в Паскале. Написать программу определения стоимости разговора по телефону за время T мин с учетом скидки 20%, предоставляемой по субботам и воскресеньям. Время 1 минуты разговора - 3 рубля 50 копеек.
Ответы (1)
Напишите программы для следующих задач, организуя экран пользователя по предложенному варианту. Задача 1:Написать программу вычисления площади поверхности параллелепипеда. S=2 * (A*B+B*C+C*A) Введите данные А=9, В=7.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Известно стоимость минуты разговора, количество проговорённых минут, номер дня недели и скидка по выходным. Написать программу нахождения стоимости разговора в зависимости от дня недели.
Ответы (1)