Задать вопрос
14 ноября, 20:35

Pascal. Помогите решить.

Дано двухзначное число. Написать программу для определения: кратна ли сумма его цифр шести?

+1
Ответы (1)
  1. 14 ноября, 21:34
    0
    Var b, a1, a2, S:integer;

    Begin

    readln (b) ; {вводим 2-ух значное число}

    a1:=b div 10;

    a2:=b mod 10;

    S:=a1+a2;

    if s mod 6=0 then writeln ('Кратно') else writeln ('не кратно') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Помогите решить. Дано двухзначное число. Написать программу для определения: кратна ли сумма его цифр шести? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)
Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Написать на языке Packal
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)