Задать вопрос
30 января, 02:19

Вывести на экран все значения функции y=sinX

на промежутке от - 1 до 1 с шагом 0,1.

паскаль

+3
Ответы (1)
  1. 30 января, 04:08
    0
    Var i:longint;

    a:real;

    begin

    for i:=1 to 10 do / / for нельзя делать по дробным числам, поэтому будем в цикле делить на 10

    begin

    a:=i; / / integer это целочисленный тип, поэтому присваиваем его значение к переменной типа real

    write (sin (a/10),' ') ; / / синус от положительного

    write (sin (- (a/10)),' ') ; / / синус от отритцательного

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести на экран все значения функции y=sinX на промежутке от - 1 до 1 с шагом 0,1. паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)