Задать вопрос
9 февраля, 22:35

Напишите программу вычисления наибольшего общего делителя двух натуральных чисел.

Используйте оператор repeat, while.

+2
Ответы (1)
  1. 9 февраля, 23:02
    0
    Function NOD (a, b: integer) : integer;

    begin

    while a b do

    if a > b then a : = a - b

    else b : = b - a;

    NOD : = a

    end;

    begin

    writeln ('НОД (264; 5436) = ', NOD (264, 5436))

    end.

    Тестовое решение:

    НОД (264; 5436) = 12
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу вычисления наибольшего общего делителя двух натуральных чисел. Используйте оператор repeat, while. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего делителя двух чисел
Ответы (1)
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел. используйте оператор repeat.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)