Задать вопрос
6 января, 09:52

Помогите решить в паскале!

Даны пять чисел,

каждое из которых по модулю не превышает ста. Вычислить максимум среди

отрицательных из них.

+5
Ответы (1)
  1. 6 января, 12:42
    0
    Var a:array[1 ... 5] of real;

    b, c:integer;

    max:real;

    begin

    c:=0;

    max:=-100;

    writeln ('Введите числа') ;

    for b:=1 to 5 do

    begin

    readln (a[b]) ;

    if (a[b]max) then begin

    max:=a[b];

    c:=c+1;

    end;

    end;

    if c>0 then writeln ('Максимум среди отрицательных чисел равняется ', max)

    else writeln ('Нет отрицательных чисел') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить в паскале! Даны пять чисел, каждое из которых по модулю не превышает ста. Вычислить максимум среди отрицательных из них. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программы на Паскале. 1. Вычислить. X - натуральное число. 2. Среди 10 введённых с клавиатуры чисел подсчитать количество отрицательных и произведение положительных. Рассмотреть случай если отрицательных чисел нет.
Ответы (1)
Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)