Задать вопрос
16 марта, 22:35

Помогите написать программу в паскале с решением ребус A+AB+ABC=BCB

+4
Ответы (1)
  1. 17 марта, 02:31
    0
    Число АВС может принимать значение от 123 до 987

    Исходя из этого пишем программу

    var

    Ast, Bst, Cst, s:string;

    i, A, AB, ABC, BCB:integer;

    f:boolean; {Признак того, что решение найдено}

    begin

    for i:=123 to 987 do

    begin

    if f=false then

    begin

    s:=IntToStr (i) ;

    Ast:=s[1]; Bst:=s[2]; Cst:=s[3];

    A:=StrToInt (Ast) ; AB:=StrToInt (Ast+Bst) ; ABC:=StrToInt (Ast+Bst+Cst) ; BCB:=StrToInt (Bst+Cst+Bst) ;

    if A+AB+ABC=BCB then f:=true;

    if (s[1]=s[2]) or (s[1]=s[3]) or (s[2]=s[3]) then f:=false; {цифры не должны повторяться}

    end

    end;

    if f=true then writeln (A,'+', AB,'+', ABC,'=', BCB) else writeln ('Решения нет')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале с решением ребус A+AB+ABC=BCB ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике