Задать вопрос
4 июля, 06:46

Дан массив из N

целых чисел а1, а2, ..., an. Проверить, есть ли в этом массиве три числа, сумма которых равна нулю.

+1
Ответы (1)
  1. 4 июля, 08:46
    0
    uses crt;

    var i, j, k, n, sum:integer;

    a:array[1 ... 100] of integer;

    flag:boolean;

    begin

    flag:=false;

    writeln ('Input N') ;

    read (n) ;

    writeln ('Input elements') ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    for j:=1 to n do

    for k:=1 to n do

    if (ij) and (jk) and (ik) then

    if a[i]+a[j]+a[k]=0 then

    begin

    writeln ('Yes') ;

    flag:=true;

    halt;

    end;

    if flag=false then

    writeln ('No') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из N целых чисел а1, а2, ..., an. Проверить, есть ли в этом массиве три числа, сумма которых равна нулю. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)
Дан массив из N целых чисел a1, a2 ..., aN. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю. Формат входных данных В певой строке входного файла содержится одно целое число n (1
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Задача D Три числа Дан массив из N целых чисел а 1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.
Ответы (1)
Три числа. Дан массив из целых N чисел а1, а2, ... аn. Нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.
Ответы (1)