Задать вопрос
18 мая, 19:09

В двумерной матрице A (N, M), состоящей из произвольных чисел, определить номера столбцов, в которых среднее арифметическое его элементов меньше чем среднее арифметическое элементов массива.

+4
Ответы (2)
  1. 18 мая, 22:08
    0
    Var

    i, j, n, m:integer;

    s:real;

    a:array[0 ... 1000,1 ... 1000] of real;

    begin

    readln (n, m) ;

    randomize;

    s:=0;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    a[i, j]:=random (10) ;

    s:=s+a[i, j];

    write (a[i, j],' ')

    end;

    writeln

    end;

    s:=s/n/m;

    writeln;

    for j:=1 to m do

    begin

    for i:=1 to n do a[0, j]:=a[0, j]+a[i, j];

    a[0, j]:=a[0, j]/n;

    if a[0, j]
    end

    end.
  2. 18 мая, 23:09
    0
    Var

    i, j, n, m: integer;

    s, t: real;

    a: array[1 ... 100, 1 ... 100] of integer;

    begin

    randomize;

    readln (n, m) ;

    for i : = 1 to n do

    begin

    for j : = 1 to m do

    begin

    a[i, j] : = random (100) ;

    s : = s + a[i, j];

    write (a[i, j]:3, ' ')

    end;

    writeln ()

    end;

    s : = s / n / m;

    writeln () ;

    for j : = 1 to m do

    begin

    t : = 0;

    for i : = 1 to n do

    t : = t + a[i, j];

    if t / n < s then

    write (j, ', ')

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерной матрице A (N, M), состоящей из произвольных чисел, определить номера столбцов, в которых среднее арифметическое его элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)