Задать вопрос
12 сентября, 02:49

Написать

программу, которая спрашивает "Который час?" и, в зависимости от введенного

времени, выводит на экран приветствие: "Доброе утро", "Добрый день", "Добрый

вечер", "Спокойной ночи".

+2
Ответы (1)
  1. 12 сентября, 03:35
    0
    Program z1;

    var a:real;

    begin

    writeln ('Который час?') ;

    read (a) ;

    if (a>=6) and (a<12) then writeln ('Доброе утро') else

    begin

    if (a>11) and (a<=16) then writeln ('Добрый день') else

    begin

    if (a>16) and (a<=22) then writeln ('Добрый вечер') else

    begin

    if (a>22) or (a<6) then writeln ('Спойкойной ночи') end; end; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая спрашивает "Который час?" и, в зависимости от введенного времени, выводит на экран приветствие: "Доброе утро", ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая спрашивает "Который час?" и, в зависимости от введенного времени, выводит на экран приветствие: "Доброе утро", "Добрый день", "Добрый вечер", "Спокойной ночи". 2.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу "Доброе утро", "Добрый день", "Добрый вечер", "Спокойной ночи" в зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"
Ответы (1)
Написать программу, которая печатает "Доброе утро","Добрый день","Добрый вечер","Спокойной ночи", в зависимости от времени, которое вводится с клавиатуры на запрос программы.
Ответы (1)
Составить программу, которая запрашивает время суток и выводит на экран соответствующие приветствие: "доброе утро" "доброго дня" "доброго вечера" "спокойной ночи"
Ответы (2)