Задать вопрос
1 июня, 06:30

Написать программу на паскаль:

Найти произведение наибольших элементов двумерного массива, первый элемент которого отрицателен.

+1
Ответы (1)
  1. 1 июня, 09:30
    0
    Если имеется в виду произведение наибольших в каждой строке элементов, то тогда так:

    var

    i, j, p:integer;

    max:array[1 ... 5]of integer;

    a:array[1 ... 5,1 ... 5]of integer;

    begin

    p:=1;

    for i:=1 to 5 do

    for j:=1 to 5 do

    a[i, j]:=random (-10,10) ;

    a[1,1]:=random (-10,-1) ;

    for i:=1 to 5 do

    begin

    for j:=1 to 5 do

    begin

    write (a[i, j]:4) ;

    if a[i, j]>max[i] then max[i]:=a[i, j];

    end;

    p:=p*max[i];

    writeln;

    end;

    writeln ('P=', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на паскаль: Найти произведение наибольших элементов двумерного массива, первый элемент которого отрицателен. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)