Задать вопрос
25 октября, 04:06

Даны натуральные числа x, y, z, определяющие возраст трех друзей. Из данных чисел напечатать те, которые обозначают ''школьный'' возраст, то есть от 7 до 16 лет.

(На языке Паскаль)

+5
Ответы (2)
  1. 25 октября, 05:42
    0
    Uses crt;

    var x, y, z, i: integer;

    begin

    clrscr;

    readln (x, y, z) ;

    case x of 7 ... 16:

    writeln (x) ;

    end;

    case y of 7 ... 16:

    writeln (y) ;

    end;

    case z of 7 ... 16:

    writeln (z) ;

    end;

    readln () ;

    end.
  2. 25 октября, 06:39
    0
    Var x, y, z:integer;

    begin

    readln (x, y, z) ;

    if x in [7 ... 16] then write (x:4) ;

    if y in [7 ... 16] then write (y:4) ;

    if z in [7 ... 16] then write (z:4) ;

    writeln; readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные числа x, y, z, определяющие возраст трех друзей. Из данных чисел напечатать те, которые обозначают ''школьный'' возраст, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Ввести последовательно возраст Антона, Бориса и Виктора. Определить, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех. На C + + или Паскаль.
Ответы (1)
Помогите составить программу) Введите исходные данные: Возраст Коли: 12 Возраст Миши: 17 Средний возраст: 14.5 лет Возраст Колт отличается от среднего возраста на: - 2.5 лет Возраст Миши отличается от среднего возраста на: 2.5 лет
Ответы (1)
даны натуральные числа от 20 до 50. Напечатать те из них которые делятся на 3. (программа паскаль)
Ответы (2)