Задать вопрос
18 марта, 19:52

Среди всех натуральных чентырехзначных чисел подсчитать кол-во таких, сумма квадратов цифр, которых кратна двум или трем.

+3
Ответы (2)
  1. 18 марта, 22:31
    0
    Var

    x, s, k, i: integer;

    begin

    for i : = 1000 to 9999 do

    begin

    x : = i;

    s : = 0;

    while x > 0 do

    begin

    s : = s + (x mod 10) * (x mod 10) ;

    x : = x div 10;

    end;

    if (s mod 2 = 0) or (s mod 3 = 0) then begin

    k : = k + 1;

    {writeln (i:5, s:5) ; }

    end;

    end;

    writeln (k) ;

    end.

    Ответ 6216
  2. 18 марта, 22:32
    0
    У меня получилось 6216

    Dim i As Integer

    Dim s As Integer

    Dim d As Integer

    For i = 1000 To 9999

    s = CInt ((CInt (Mid (CStr (i), 1, 1))) ^ 2 + (CInt (Mid (CStr (i), 2, 1))) ^ 2 + (CInt (Mid (CStr (i), 3, 1))) ^ 2 + (CInt (Mid (CStr (i), 4, 1))) ^ 2)

    If s Mod 2 = 0 Or s Mod 3 = 0 Then d + = 1

    Next

    MsgBox (d)

    P. S. Прошу прощения за прошлый ответ, перепутал и соединил две задачи=)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Среди всех натуральных чентырехзначных чисел подсчитать кол-во таких, сумма квадратов цифр, которых кратна двум или трем. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Среди всех натуральных четырехзначных чисел подсчитать количество таких, сумма квадратов цифр, которых кратна двум или трем. Ответ дайте целым числом
Ответы (1)
Среди всех натуральных четырехзначных чисел подсчитать количество таких, сумма квадратов цифр которых кратна двум или трем. Ответ записать целым числом.
Ответы (1)
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)