Задать вопрос
23 февраля, 09:25

Написать программу, которая решает уравнение ax+b = 0 (Паскаль)

использовать эти ур. в качестве решения: 2x+4=0; 2x+0=0; 0x+2=0; 0x+0=0

+1
Ответы (1)
  1. 23 февраля, 10:29
    0
    Var a, b, x:real;

    begin

    writeln ('Введите значение a') ;

    readln (a) ;

    writeln ('Введите значение b') ;

    readln (b) ;

    x: = ((-1) * b) / a;

    if (a=0) and (b=0) then writeln ('х-любое число')

    else if (a=0) and (b0) then writeln ('Нет корней')

    else writeln ('x=', x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая решает уравнение ax+b = 0 (Паскаль) использовать эти ур. в качестве решения: 2x+4=0; 2x+0=0; 0x+2=0; 0x+0=0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)