Задать вопрос
28 мая, 19:43

В одномерном массиве A (N) найти max элемент и вставить за ним элемент равный 2*max. язык программирования паскаль

+2
Ответы (1)
  1. 28 мая, 22:18
    0
    Program z1;

    var a:array[1 ... 100] of integer;

    i, n, ma, mau:integer;

    begin

    assign (input,'in. txt') ;

    reset (input) ;

    readln (n) ;

    for i:=1 to n do begin

    read (a[i]) ;

    end;

    close (input) ;

    ma:=a[1]; mau:=1;

    for i:=1 to n do begin

    if a[i]>ma then begin

    ma:=a[i]; mau:=i

    end;

    end;

    a[mau+1]:=2*ma;

    if mau=n then n:=n+1;

    assign (output,'out. txt') ;

    rewrite (output) ;

    for i:=1 to n do begin

    write (a[i],' ')

    end;

    close (output)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве A (N) найти max элемент и вставить за ним элемент равный 2*max. язык программирования паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Паскаль Как написать программу, которая уменьшала бы ВСЕ максимальные элементы в два раза? Так? max:=a[1,1]; if a[i, j] > max then max: = a[i, j]; end; max: = max div 2;
Ответы (2)
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве. Составить схему алгоритма и программу на языке программирования Basic для решения задачи по обработке одномерного массива.
Ответы (1)