Задать вопрос
10 июня, 06:06

Волк погнался за зайцем по бесконечной дороге. Когда волк делает m скачков, заяц делает n скачков. Скачок зайца в 2 раза короче скачка волка, а скачок волка равен k метров. Какое расстояние пробежит волк, чтобы догнать зайца. Если первоначальное расстояние между ними равно d

+2
Ответы (1)
  1. 10 июня, 09:28
    0
    Var

    m, n: integer;

    k, d, s: real;

    begin

    read (m, n, k, d) ;

    repeat

    d : = d - m * k + n * k / 2;

    s : = s + m * k;

    until d < = 0;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Волк погнался за зайцем по бесконечной дороге. Когда волк делает m скачков, заяц делает n скачков. Скачок зайца в 2 раза короче скачка ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Файл input. txt: Мама, короче, мыла, короче, раму. Декан, короче, пропил, короче, бутан. А роза, короче, упала на лапу, короче, Азора. Каждый, короче, охотник желает, короче, знать, где короче сидит фазан В файле input.
Ответы (1)
На маскарад буратино, артемон, пьеро и мальвина одели маски волка, лисы, тигра и зайца и стали по кругу. кто какую одел маску, если артемон стоит между пьером и зайцем, а мальвина - не волк и не заяц и стоит между бу ратино и тигром?
Ответы (1)
У четырех девочек Маши, Светы, Тани и Оли были четыре игрушки: заяц, мишка, кукла и паровоз. Известно, что у Светы не было мишки. Игрушка Оли лежала рядом с куклой и зайцем. Таня дала поиграть своей игрушкой девочке с зайцем.
Ответы (2)
Бумажные фигурки зайца, медведя, волка, лисы выполнены из белой, синей, красной и зеленой бумаги. Медведь не белый и не зеленый, синяя фигура лежит между волком и красной фигурой, лиса не синяя и не зеленая, заяц лежит между лисой и белой фигурой.
Ответы (1)
Написать программу в Паскале: Заяц в первый день пробегает 40 км, во второй день на 3 км больше. Вывести ответ, сколько км заяц пробежит за 7 дней.
Ответы (1)