Задать вопрос
27 августа, 07:27

Посчитать количество предложений в файле (тема: строковый тип данных). т. е написать программу

+3
Ответы (1)
  1. 27 августа, 09:18
    0
    Не работает с многоточием, если что.

    var f:text; c:char; k:integer;

    begin

    k:=0;

    assign (f,'input') ;

    reset (f) ;

    while eof (f) = false do

    if eoln (f) then readln (f)

    else

    begin

    read (f, c) ;

    if (c='.') or (c='!') or (c='?') then k:=k+1;

    end;

    if not ((c='.') or (c='!') or (c='?')) then k:=k+1;

    close (f) ;

    write (k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Посчитать количество предложений в файле (тема: строковый тип данных). т. е написать программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)
Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean
Ответы (1)
Определить, сколько фамилий в списке состоят из 8 или 9 букв. (тема: строковый тип данных)
Ответы (2)
Открыть в редакторе Microsoft Word произвольный текстовый файл (без графических элементов), определить количество символов в этом файле, включая пробелы (команда Файл - " Свойства), и вычислить количество информации в этом файле.
Ответы (1)
Открыть произвольный текстовый файл (без графических элементов, размером не менее 1 страницы) определить полное количество символов в этом файле, вычеслить количество Кбит информации в этом файле
Ответы (1)