Задать вопрос
28 февраля, 15:35

Даны строки S, S1, S2. Заменить в строке S все вхождения строки S1 на строку S2.

+4
Ответы (1)
  1. 28 февраля, 17:44
    0
    Var

    s1, s2, s3:string;

    i, j:longint;

    begin

    readln (s1, s2, s3) ;

    for i:=1 to length (s1) ;

    begin

    k:=pos (s2, s1) ;

    if k>0 then begin

    delete (s1, k, length (s2)) ;

    insert (s2, s1, k) ; {Не помню точно, в каком порядке первые 2 переменные}

    writeln (s1) ; end else exit; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны строки S, S1, S2. Заменить в строке S все вхождения строки S1 на строку S2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вася учится в школе. Недавно учитель записал на доске строку из строчных латинских букв и цифр, а Вася переписал эту строку в тетрадку. Придя домой, Вася столкнулся с проблемой в прочтении строки.
Ответы (1)
Даны n строк, каждая имеет свой номер - от 0 до n. В нулевой строке записано число 0. Все остальные строки формируются по следующему правилу: в k-ю строку дважды записывается (k-1) - я строка, затем в конец строки записывается её номер k.
Ответы (1)
Программы с процедурой вставки В строку s1 занесите свои фамилию и отчество (через пробел). В строку s2 занесите свое имя. С помощью процедуры вставки измените строку s1 таким образом, чтобы она содержала Ваши фамилию, имя, отчество.
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
Программирование, язык Turbo Pascal. Ввести строку с клавиатуры. Заменить все вхождения буквы "а" (рус и англ) на пробел. Через функцию copy
Ответы (1)