Задать вопрос
9 января, 05:38

Написать программу, которая проверяет - образуют ли элементы заданного массива возрастающую последовательность.

+4
Ответы (1)
  1. 9 января, 09:26
    0
    Var arr : array of integer; len, i : integer; begin write ('Введите размер массива: ') ; readln (len) ; SetLength (arr, len) ; for i : = 0 to len - 1 do begin write ('arr[', i, '] = ') ; readln (arr[i]) ; end; for i : = 1 to len - 1 do if arr[i] < = arr[i - 1] then begin writeln ('Последовательность не возрастающая') ; Exit; end; writeln ('Последовательность возрастающая') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая проверяет - образуют ли элементы заданного массива возрастающую последовательность. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)