Задать вопрос
23 апреля, 07:48

Помогите создать программу в Паскале с помощью задачи - даны три отрезка а, в, с определить можно ли из этих отрезков получить треугольник, и если да то какой

+4
Ответы (1)
  1. 23 апреля, 10:21
    0
    Из трех отрезков a, b, c можно составить треугольник, если выполняется неравенство треугольника: сумма длин двух любых сторон треугольника строго больше длины третьей.

    program triangle;

    var a, b, c:integer;

    res:string;

    begin

    readln (a, b, c) ; { отсортировать a, b, c. Имеем: a < = b < = c }

    if c > = a + b then res : = 'Не возможно!' else

    if c*c = a*a + b*b then res : = 'Возможно, прямоугольный.' else

    if c*c < a*a + b*b then res : = 'Возможно, остроугольный. ' else

    res : = 'Возможно, тупоугольный ';

    writeln (res) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите создать программу в Паскале с помощью задачи - даны три отрезка а, в, с определить можно ли из этих отрезков получить треугольник, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На диске D необходимо выполнить следующую последовательность действий:, Создать каталог МИН, Открыть каталог МИН, Создать каталог 1, Открыть каталог 1, Создать каталог 11, Подняться на 1 уровень вверх, Создать каталог 2, Подняться на 1 уровень
Ответы (1)
1) Требовалось написать программу, 1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение.
Ответы (1)
1. Как создать новую презентацию в макете пустой слайд? 2, Как создать оформление фона собственного стиля? 3, Как создать презентацию на основе шаблона? 6. Как создать презентацию с собственным шаблоном оформления?
Ответы (1)
Решите задачи в паскале abc. 1) Даны длины отрезков A и B (A>B). Рассчитать количество полных отрезков B, которые могут быть размещены на отрезке A. 2) Идет К-я секунда суток. Какое время показывают электронные часы
Ответы (1)
Создать на Паскале форму. 1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
Ответы (1)