Задать вопрос
24 ноября, 06:57

Решите задачи в паскале abc.

1) Даны длины отрезков A и B (A>B). Рассчитать количество полных отрезков B, которые могут быть размещены на отрезке A.

2) Идет К-я секунда суток. Какое время показывают электронные часы

+2
Ответы (1)
  1. 24 ноября, 10:35
    0
    Первое можно решить двумя способами простой и сиклами

    var a, b:integer;

    k:integer;

    begin

    readln (a, b) ;

    writeln (a div b) ;

    или

    k:=0;

    while a>0 do begin a:=a-b;

    inc (k) ;

    end;

    writeln (k) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите задачи в паскале abc. 1) Даны длины отрезков A и B (A>B). Рассчитать количество полных отрезков B, которые могут быть размещены на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Идет какая-то секунда суток. Определите сколько полных часов, полных минут и секунд прошло с начала суток
Ответы (1)
1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько полных секунд прошло сначала текущей минуты.
Ответы (1)
Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.
Ответы (1)
Даны положительные числа А и В (А>В). На отрезке длины А размещено максимально возможное количество отрезков длины В (без наложений). Не используя операции умножения и деления, найти количество отрезков В, размещенных на отрезке А.
Ответы (1)
Идёт k-я секунда суток. Определить, сколько полных часов (H) и полных минут (M) прошло к этому моменту.
Ответы (2)