Задать вопрос
20 декабря, 11:29

Найти частное произведений четных и не четных цифр четырехзначного числа n

+1
Ответы (2)
  1. 20 декабря, 12:36
    0
    Var

    i, n, x:integer;

    a:array[1 ... 4]of integer;

    begin

    readln (n) ;

    for i:=4 downto 1 do

    begin

    x:=n mod 10;

    a[i]:=x;

    n: = (n-x) div 10;

    end;

    writeln ('Произведение четных: ', a[2]*a[4]) ;

    writeln ('Произведение нечетных: ', a[1]*a[3]) ;

    end.

    Если можно использовать строковые функции, то будет проще:

    var

    i:integer;

    n:string;

    a:array[1 ... 4]of integer;

    begin

    readln (n) ;

    for i:=1 to 4 do a[i]:=StrToInt (n[i]) ;

    writeln ('Произведение четных: ', a[2]*a[4]) ;

    writeln ('Произведение нечетных: ', a[1]*a[3]) ;

    end.
  2. 20 декабря, 12:39
    0
    Есть книжка такая, "Песни о Паскале". Глава 47.

    Нужно разложите число на цифры и вычислить соответствующие произведения,

    flag: false; m1: = 1; m2: = 1;

    while N 0 do begin

    if flag then m1: = m1 * (N mod 10) else m2: = m2 * (N mod 10) ;

    flag: = not flag;

    N: = N div 10;

    end;

    if m10 then Writeln (m2 div m1) else Writeln ('Бесконечность') ;

    Видела уже такой вопрос где-то года три назад.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти частное произведений четных и не четных цифр четырехзначного числа n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма четных цифр и сумма нечетных цифр заданного числа. 2.
Ответы (1)