Задать вопрос
4 мая, 05:57

Написать

программу pascal, которая меняет местами последние две цифры в записи числа.

Рассматриваются числа в диапазоне от m до n, причем m>99. Вывести на экран два столбика значений: первый - исходное

число, второй - измененное.

+3
Ответы (1)
  1. 4 мая, 07:12
    0
    Uses crt;

    var i, n, m: integer;

    begin

    write ('Введите число, большее 99: ') ;

    readln (n) ;

    clrscr;

    for i:=100 to n do

    writeln (i,' ', i div 100, i mod 10, i mod 100 div 10) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу pascal, которая меняет местами последние две цифры в записи числа. Рассматриваются числа в диапазоне от m до n, причем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)