Задать вопрос
7 августа, 05:09

Дано целое положительное четырехзначное число а.

Найти минимальную цифру среди первых трех цифр числа, а также определить: первая или вторая цифра числа четная, или обе цифры четные, или обе цифры нечетные. Результаты вывесите на экран.

+3
Ответы (1)
  1. 7 августа, 06:56
    0
    Uses crt;

    label goback;

    var

    a, b, c, d, e, f:integer;

    begin

    goback:

    write ('Введите число: ') ; read (a) ;

    if (a9999) then

    begin

    writeln ('Введите четырехзначное число.') ;

    goto goback;

    end;

    b:=a div 1000;

    c:=a div 100 mod 10;

    d:=a div 10 mod 10;

    if (b=c) and (c=d) then begin writeln ('Первые 3 цифры равны.') ; end;

    if (b=c) and (c>d) then begin writeln (d,' - Наименьшая цифра из первых 3 цифр.') ; end;

    if (d=b) and (b>c) then begin writeln (c,' - Наименьшая цифра из первых 3 цифр.') ; end;

    if (c=d) and (d>b) then begin writeln (b,' - Наименьшая цифра из первых 3 цифр.') ; end;

    if (b>c) and (c>d) and (b>d) then begin writeln (d,' - Наименьшая цифра из первых 3 цифр.') ; end;

    if (c>d) and (d>b) and (c>b) then begin writeln (b,' - Наименьшая цифра из первых 3 цифр.') ; end;

    if (b>d) and (d>c) and (b>c) then begin writeln (c,' - Наименьшая цифра из первых 3 цифр.') ; end;

    if (b mod 2 = 0) then begin writeln ('Первая цифра четная') ; end; if (c mod 2 = 0) then begin writeln ('Вторая цифра четная') ; end;

    if (b mod 2 = 0) and (c mod 2 = 0) then begin writeln ('И первая и вторая цифра четная') ; end;

    if (b mod 2 = 1) and (c mod 2 = 1) then begin writeln ('И первая и вторая цифра не четная') ; end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое положительное четырехзначное число а. Найти минимальную цифру среди первых трех цифр числа, а также определить: первая или ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)