Задать вопрос
18 августа, 07:14

Программирование циклов. Составьте программу.

C клавиатуры вводят 6 целых чисел. Определите количество четных чисел в этом наборе.

+3
Ответы (1)
  1. 18 августа, 08:57
    0
    Program ten;

    const n=2;

    Var a, b, c, d, e, f, p:integer;

    Begin

    Write ('Введите число a ') ; Read (a) ;

    Write ('Введите число b ') ; Read (b) ;

    Write ('Введите число c ') ; Read (c) ;

    Write ('Введите число d') ; Read (d) ;

    Write ('Введите число e ') ; Read (e) ;

    Write ('Введите число f ') ; Read (f) ;

    p:=0;

    If a mod n = 0 Then P:=p+1;

    If b mod n = 0 Then P:=p+1;

    If c mod n = 0 Then P:=p+1;

    If d mod n = 0 Then P:=p+1;

    If e mod n = 0 Then P:=p+1;

    If f mod n = 0 Then P:=p+1;

    Write ('количество четных чисел = ', p) ;

    end.

    Вот так, программа работает.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование циклов. Составьте программу. C клавиатуры вводят 6 целых чисел. Определите количество четных чисел в этом наборе. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
помогите решить задачю по информатике С клавиатуры последовательно вводят целые числа и высчитывается их сумма если с клавиатуры вводят 0, то больше числа не вводят. Найти сумму всех введеных чисел.
Ответы (1)
Программирование циклических алгоритмов. Программирование циклов с заданнымусловием продолжения работы. Задача: Клиент открыл счет в банке в 2017 году, вложив 1000 рублей.
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих данного заданного числа N. Напишите программу на Паскале. P. S. Тема урока - программирование циклов
Ответы (1)
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. Программа получает на вход количество чисел в последоввтельности, а затем сами числа. Количество чисел не привышает 1000.
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)