Задать вопрос
24 марта, 02:51

Информация о количестве жильцов в каждой из четырех квартир каждого этажа 12-этажного дома хранится в двумерном массиве (в первой строке - информация о квартирах первого этажа, во второй - второго и т. д.). В каждой квартире проживает одна семья. Найти численность самой большой семьи в квартирах 3-го и 4-го этажей. (Pascal)

+4
Ответы (1)
  1. 24 марта, 05:36
    0
    Var

    a : array [1 ... 12, 1 ... 4] of integer;

    i, j, max : integer;

    begin

    for i : = 1 to 12 do

    for j : = 1 to 4 do

    read (a[i, j]) ;

    max : = a[3, 1];

    for i : = 3 to 4 do

    for j : = 1 to 4 do

    if a[i, j] > max then max : = a[i, j];

    write (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информация о количестве жильцов в каждой из четырех квартир каждого этажа 12-этажного дома хранится в двумерном массиве (в первой строке - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать код в с# В двумерном массиве хранится информация о количестве учеников каждом из четырех классов каждой параллели школы с первой по одиннадцатую (в первой строке - информация о первых классах, во второй - вторых и т. д.).
Ответы (1)
Написать программу в с# двумерный массив В двумерном массиве хранится информация о количестве учеников каждом из четырех классов каждой параллели школы с первой по одиннадцатую (в первой строке - информация о первых классах, во второй - вторых и т.
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
В двухмерном массиве в строках хранится информация об оценках каждого из 20 учеников класса по тому или иному предмету (в первой строке - информация об оценках первого ученика, во второй - второго и т. д.). Общее число предметов равно 10.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)