Задать вопрос
27 августа, 04:29

Определить, можно ли квадрат со стороной a поместить в окружность заданного радиуса R?

Входные данные:

Во входном потоке задано два вещественных числа - радиус окружности R и сторона квадрата a. Значение всех исходных величин не превышает 30000.

Выходные данные:

В выходной поток вывести 'YES' или 'NO'.

Пример входного файла

2 1

Пример выходного файла

YES

+1
Ответы (1)
  1. 27 августа, 06:25
    0
    Программа на Паскале:

    Program BiFi;

    Var R, a:real;

    Begin

    readln (R, a) ;

    if a< = (R*sqrt (2)) then writeln ('Yes') ;

    else writeln ('NO') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, можно ли квадрат со стороной a поместить в окружность заданного радиуса R? Входные данные: Во входном потоке задано два ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат. Входные данные: Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
В кафе продается мороженое по 3 или по 5 шариков в порции. Определить, можно ли купить K шариков мороженного. Входные данные: Во входном потоке в первой строке задано натуральное число К (K < = 1000) Выходные данные: Вывести YES или NO.
Ответы (2)