Задать вопрос
24 марта, 19:34

Для заданного х вычислите у по формуле у=*^3+2,5*-*+1.

При этом:

А) операцию возведения в степень использовать запрещено;

Б) в одном операторе присваивания можно использовать не более одной арифметической операции (сложение, умножение, вычитание) ;

Подсказка: преобразуйте выражение к следующему виду:

у = ((*+2,5) * - 1) * + 1.

+2
Ответы (1)
  1. 24 марта, 21:20
    0
    Var x:integer; y:real;

    begin

    readln (x) ;

    y:=x+2.5;

    y:=y*x;

    y:=y-1;

    y:=y*x;

    y:=y+1;

    writeln (y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для заданного х вычислите у по формуле у=*^3+2,5*-*+1. При этом: А) операцию возведения в степень использовать запрещено; Б) в одном ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
1) Преобразуйте следующее двоичное число в восьмеричное: 10011 2) Преобразуйте следующее двоичное число в десятеричное: 101100 3) Преобразуйте следующее двоичное число в шестнадцатеричное: 1011000111 4) Преобразуйте следующее восьмеричное число в
Ответы (1)
1) Преобразуйте слудующее двоичное число в восьмеричное: 10011000. 2) Преобразуйте слудующее двоичное число в десятичное: 11101101. 3) Преобразуйте слудующее двоичное число в шестнадцатеричное: 1011111110.
Ответы (2)
Используя числа 1, 3, 4, 6, арифметические операции (сложение, вычитание, умножение, деление) и скобки, получить число 24. Разрешается использовать только эти числа и только эти операции. Каждое число должно использоваться один и только один раз.
Ответы (1)
Используя однозначные числа 1,3,4,6 арифметические операции (сложение, вычитание, умножение, деление) и скобки, получите 24. Разрешается использовать только эти числа, и только эти операции. Каждое число должно использоваться один и только один раз.
Ответы (1)