Задать вопрос
10 января, 23:53

Написать программу для паскаля. Дана квадратная матрица

порядка n (n=5).

Если в данной матрице a нет отрицательных элементов,

то транспонировать её, иначе выдать сообщение.

+5
Ответы (1)
  1. 11 января, 00:43
    0
    Uses crt;

    const N=2;

    var a:array [1 ... N, 1 ... N] of real;

    i, j, k:integer;

    begin

    k:=0; writeln ('Введите матрицу:') ;

    for i:=1 to N do

    for j:=1 to N do

    begin

    read (a[i, j]) ;

    if a[i, j]<0 then inc (k) ;

    end;

    if k>0 then writeln ('В матрице отрицательный элемент')

    else

    for i:=1 to N do

    begin

    for j:=1 to N do

    write (a[j, i]:3:0) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для паскаля. Дана квадратная матрица порядка n (n=5). Если в данной матрице a нет отрицательных элементов, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана квадратная матрица порядка N. В матрице вычислить среднее арифметическое положительных элементов, стоящих на главной диагонали.
Ответы (2)
Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исходной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в
Ответы (1)
23. Дана действительная квадратная матрица порядка n. Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.
Ответы (1)
Написать программу для решения следующей задачи: дана квадратная матрица порядка N. Заменить единицами все элементы, стоящие на главной диагонали и выше ее.
Ответы (1)
Дана целая квадратная матрица, n - го порядка. Определить, является ли она магическим квадратом, т. е. такой, в которой сумма элементов во всех строках и столбцах одинаковая. Нужна адекватная программа уровня 11 класса на паскале.
Ответы (1)