Задать вопрос
12 мая, 07:23

Составьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет среднее арифметическое элементов массива. 0

+3
Ответы (1)
  1. 12 мая, 09:26
    0
    Const N=10;

    var a:array [1 ... N] of integer;

    i, sum:integer;

    sr:real;

    begin

    sr:=0; sum:=0;

    for i:=1 to N do

    begin

    a[i]:=random (10) + 1;

    sum:=sum+a[i];

    end;

    for i:=1 to N do

    write (a[i]:3) ;

    writeln;

    sr:=sum/10;

    writeln ('Среднее значение элементов массива:', sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет среднее арифметическое элементов этого массива.
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)