Задать вопрос
11 мая, 01:26

Напишите программу, которая находит в массиве количество элементов, равных заданному значению Х.

+3
Ответы (1)
  1. 11 мая, 01:36
    0
    Program red;

    var

    a:array[1 ... 100] of integer;

    b, c, i, n:integer;

    begin

    writeln ('Vvedite 4islo') ;

    readln (b) ;

    writeln ('Vvedite razmer massiva') ;

    readln (n) ;

    c:=0;

    for i:=1 to n do

    a[i]:=random (10) ;

    for i:=1 to n do

    if a[i]=b then c:=c+1;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая находит в массиве количество элементов, равных заданному значению Х. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Питон Напишите программу, которая находит в массиве количество элементов, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)