Задать вопрос
28 марта, 13:53

найдите сумму нечётных отрицательных чисел на промежутке [-36; 36] делящихся на 7

(составить программу)

+5
Ответы (1)
  1. 28 марта, 15:33
    0
    Program p1;

    const n=10;

    var a: array [1 ... n] of integer;

    s, i: integer;

    begin

    randomize;

    for i: = 1 to n do

    begin

    a[i]: = random (73) - 36

    ; write (a[i]:3) ;

    end;

    s:=0;

    for i:=1 to n do

    begin

    if (a[i] mod 20) and (a[i] mod 7=0) then

    begin

    s:=s+a[i];

    end;

    end;

    writeln;

    writeln ('сумма=', s) ;

    end.

    единственное не учел момент когда таких числе нет, можете дописать
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найдите сумму нечётных отрицательных чисел на промежутке [-36; 36] делящихся на 7 (составить программу) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, сумму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b
Ответы (1)
C# Ввести n целых чисел (без массивов). Выяислить и вывести: a) сумму чисел, заканчивающихся на 3 и 4 б) произведение чисел, делящихся на 5 но не делящихся на 3
Ответы (1)