Задать вопрос
9 июля, 04:08

Программирование на паскале.

Найти среднее арифметическое положительных чётных чисел натурального ряда до N.

(Использование цикличного оператора for)

+4
Ответы (1)
  1. 9 июля, 05:09
    0
    Uses crt;

    var s:real; n, i, k:integer;

    Begin

    clrscr;

    Write ('n=') ; readln (n) ;

    s:=0;

    k:=0;

    for i:=1 to n do

    if i mod 2=0 then begin

    s:=s+i;

    k:=k+1;

    end;

    s:=s/k;

    writeln ('srednee=', s) ;

    writeln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование на паскале. Найти среднее арифметическое положительных чётных чисел натурального ряда до N. (Использование цикличного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Нужно написать программу на паскале обязательно используя цикл For. Программа вычисляет среднее арифметическое положительных элементов ряда чисел. Каждый элемент ряда вычисляется по формуле: (12*K-21) / 3, где K--номер элемента в ряду.
Ответы (1)
Помогите решить задачи на цикл с параметром. Решения оформить как в Паскале. 1) задать 5 чисел. найти среднюю сумму положительных чисел, произведение чисел, некратных 12 и количество четных чисел среди заданных 2) В фирме работают 5 сотрудников.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)