Задать вопрос
20 февраля, 11:41

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отриц

+2
Ответы (1)
  1. 20 февраля, 13:52
    0
    Var a, b, p, n:integer;

    begin

    writeln ('Введите два числа:') ;

    readln (a, b) ;

    n:=abs (b) ;

    if (a=0) or (b=0) then

    writeln (a,'*', b,'=0')

    else begin

    while (n0) do begin

    n:=n-1;

    p:=p+abs (a)

    end;

    if (a>0) and (b>0) then writeln (a,'*', b,'=', p) ;

    if (a<0) and (b<0) then writeln (' (', a,') ','*',' (', b,') ','=', p) ;

    if (a>0) and (b<0) then writeln (a,'*',' (', b,') ','=-', p) ;

    if (a0) then writeln (' (', a,') ','*', b,'=-', p) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу которая получает два целых числа и находит их произведение не используя операцию умножения. учтите что числа могут быть отрицательными
Ответы (1)
Python Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Ответы (1)
Напишите программу в паскале, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)