Задать вопрос
22 октября, 21:25

Решите задачу с циклами While и if: Определите количество четных элементов в последовательности, завершающейся числом 0.

+2
Ответы (1)
  1. 23 октября, 00:54
    0
    Как я понял, нужно определить четные элементы массива.

    Var a:array[1 ... 6] of integer;

    x, n:integer;

    begin

    For x:=1 to 6 do

    read (a[x]) ;

    n:=0;

    For x:=1 to 6 do

    If a[x] mod 2=0 then n:=n=1;

    Writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите задачу с циклами While и if: Определите количество четных элементов в последовательности, завершающейся числом 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определите количество четных элементов в последовательности, завершающейся числом 0. Само число 0, и все, что следует за ним, учитывать не нужно.
Ответы (1)
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)
Определите среднее значение всех элементов последовательности, завершающейся числом 0. Использовать массивы в данной задаче нельзя.
Ответы (1)
Написать программу с циклами for, while, do while a=2,5 m-изменяется от 1 до10 с шагом 1.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)