Задать вопрос
2 июля, 13:39

Определите среднее значение всех элементов последовательности, завершающейся числом 0.

Использовать массивы в данной задаче нельзя.

Входные данные

Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1

7

9

0

выходные данные

5.66666666667

+1
Ответы (1)
  1. 2 июля, 16:00
    0
    А массив тут и не нужен. Накапливаем сумму и подсчитываем количество введенных чисел. Их этих двух величин получаем среднее.

    var

    m, n, s:integer;

    begin

    s:=0; n:=0;

    repeat

    Read (m) ;

    if m0 then begin s:=s+m; n:=n+1 end

    until m=0;

    if n>0 then Writeln (s/n)

    else Writeln ('Ничего не введено')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите среднее значение всех элементов последовательности, завершающейся числом 0. Использовать массивы в данной задаче нельзя. Входные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.
Ответы (1)