Задать вопрос
20 ноября, 15:52

Подсчитать количество элементов одномерного массива, которые совпадают со своим номером

+1
Ответы (1)
  1. 20 ноября, 18:36
    0
    Такая ситуация выпадает не очень часто, поэтому запускай программу несколько раз подряд. Можно повысить вероятность, но это усожнит программу.

    var

    i, n: integer;

    k: array[1 ... 10]of integer;

    begin

    for i : = 1 to 10 do

    begin

    k[i] : = random (10) + 1;

    write (k[i],' ') ;

    if k[i]=i then n:=n+1;

    end;

    writeln;

    writeln ('Число искомых элементов: ', n)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать количество элементов одномерного массива, которые совпадают со своим номером ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
С клавиатуры задается число N не превышающее 20, определяющее количество элементов одномерного целочисленного массива. Затем вручную заполняется сам массив из N элементов.
Ответы (1)