Задать вопрос
28 января, 04:22

Составить алгоритм на языке программирования, который выводит среднее арифметическое наибольшего и наименьшего из 20 элементов, имеющих значение из интервала [-10; 10]

+5
Ответы (1)
  1. 28 января, 07:52
    0
    Pascal:

    const n=20;

    var a: array[1 ... n] of integer;

    max, min, i: integer;

    begin

    max:=-11;

    min:=11;

    for i:=1 to n do begin

    a[i]:=random (20) - 10; {или readln (a[i]) ; если нужен конкретный ввод}

    if a[i]>max then max:=a[i];

    if a[i]
    end;

    writeln ((max+min) / 2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм на языке программирования, который выводит среднее арифметическое наибольшего и наименьшего из 20 элементов, имеющих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Решение есть. нужно его объяснить. Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди элементов, имеющих четные значения, и максимального среди элементов имеющих нечетные значения, в
Ответы (1)
1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.
Ответы (1)
Задачи на записи и файлы. № 1. Пусть дан файл целых чисел. Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого интервала. № 2. Имеется типизированный файл с числами.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)