Задать вопрос
27 мая, 20:43

Найдите суммы положительных и отрицательных чисел из заданных n чисел. Определите наибольшее из сумм по абсолютной величине

+5
Ответы (1)
  1. 27 мая, 23:45
    0
    Program_z1;

    var n, So, Sp, i:integer;

    begin

    read (n) ;

    So:=0;

    Sp:=0;

    for i:=1 to n do begin

    if i>0

    then Sp:=Sp+i

    else So:=So+i;

    end;

    if So>Sp

    then write ('So', So)

    else write ('Sp', Sp) ;

    readln; readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите суммы положительных и отрицательных чисел из заданных n чисел. Определите наибольшее из сумм по абсолютной величине ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
Помогите с кодом по паскалю.→Нужно чтобы ответ который показывается было написано первый столбец столько положительных чисел а если нет положительных чисел в столбце то писало нет положительных чисел в этом столбце←Столбцы пронумеровать Изначально
Ответы (1)
6. Составить алгоритм и написать программу вычисления суммы и среднего значения только отрицательных чисел из вводимых N произвольных (как положительных, так и отрицательных) целых чисел. N не больше 10
Ответы (1)