Задать вопрос
5 июля, 09:39

Дан треугольник со сторонами a, b, с. Определить, является ли он равносторонним. На Pascal ABC

+2
Ответы (1)
  1. 5 июля, 13:00
    0
    Var a, b, c:real;

    begin

    repeat

    write ('Введите длины сторон треугольника a, b, c ') ;

    readln (a, b, c) ;

    until (a>0) and (b>0) and (c>0) ;

    if (a=b) and (b=c) then writeln ('Равносторонний')

    else writeln ('Не равносторонний или такой треугольник не существует') ;

    end.

    Тест №1

    Введите длины сторон треугольника a, b, c 5 5 - 5

    Введите длины сторон треугольника a, b, c 5 5 5

    Равносторонний

    Тест №2

    Введите длины сторон треугольника a, b, c 5 6 5

    Не равносторонний или такой треугольник не существует
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан треугольник со сторонами a, b, с. Определить, является ли он равносторонним. На Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите програвмирования на языке программирования Pascal: 1) Определить является ли треугольник со сторонами a, b, c равносторонним. 2) Даны m и n. Если m≠0, то заменить каждое из чисел большим из них числом, иначе заменить 0.
Ответы (1)
Даны три стороны треугольника. определить существует ли треугольник с заданными сторонами, если да, то определить является ли он прямоугольным, равнобедренным или равносторонним, какой треугольник тупоугольный или остроугольный.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)