Задать вопрос
21 июня, 11:44

Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом.

+4
Ответы (1)
  1. 21 июня, 15:37
    0
    Program gt;

    var a:array[1 ... 1000]of integer;

    n, r, p, s, i:integer;

    begin

    read (N) ;

    p:=1; s:=0;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if (i mod 2=1) then p:=p*a[i] else s:=s+a[i];

    end;

    r:=p-s;

    writeln (r) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Перевести числа в десятичную систему счисления 11011,11 с индексом 2 ... 7512,35 с индексом 8 и число FAD, E8 с индексом 16
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)