Задать вопрос
14 июня, 17:13

Составить алгоритм и программу для подсчета количества нулей в десятичной записи целого числа.

+5
Ответы (1)
  1. 14 июня, 17:42
    0
    Var

    a, i, k:integer;

    begin

    readln (a) ;

    while a0 do begin

    if a mod 2=0 then

    k:=k+1;

    a:=a div 2;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм и программу для подсчета количества нулей в десятичной записи целого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Сколько единиц в двоичной записи числа 67,5? 2) Сколько единиц в двоичной записи числа 23,375? 3) Сколько значащих нулей в двоичной записи числа 19,125? 4) Сколько значащих нулей в двоичной записи числа 37,875?
Ответы (1)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Дано натуральное число N (N> 9). Определить количество нулей в цифровой записи числа, кроме нулей в младших разрядах. Пример. N=10 025 000. Количество нулей равно двум.
Ответы (1)
Некоторый алгоритм из одного числа получает новое число следующим образом. Исходное число записывается дважды (друг за другом), а в конец получившегося числа дописывается столько нулей, сколько четных цифр в исходном числе.
Ответы (1)