Задать вопрос
17 февраля, 14:39

Создать программу нахождения количества всех положительных элементов массива

+3
Ответы (1)
  1. 17 февраля, 17:38
    0
    Writeln ('Введите количество элементов в массиве') ;

    readln (n) ;

    for i:=1 to n do

    begin

    writeln ('Введите элемент массива') ;

    readln (A[i]) ;

    end;

    Sum:=0;

    for i:=1 to n do

    if a[i]>0 then

    Sum:=Sum+a[i];

    Writeln ('Сумма положительных элементов = ' Sum)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создать программу нахождения количества всех положительных элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Дана программа нахождения суммы всех элементов массива. Изменить программу таким образом, чтобы: a) массив состоял из 15 элементов вещественного типа; b) значения элементов массива должны меняться в интервале от 0 до 5;
Ответы (1)