Задать вопрос
22 мая, 04:17

Определить максимальное значение среди положительных элементов из N введеных

+2
Ответы (1)
  1. 22 мая, 05:23
    0
    Program gt;

    var a, i, n, max:longint;

    begin

    read (N) ;

    max:=0;

    for i:=1 to n do

    begin

    read (A) ;

    if (a>max) then max:=a;

    end;

    if (max=0) then writeln ('положительных чисел нет') else writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить максимальное значение среди положительных элементов из N введеных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)
Выполнить в paskal N=12 Ввести число К Определить количество элементов массива, значения которых больше K. ... Все элементы массива увеличить в 3 раза. Массив вывести. ... Определить максимальное значение сред положительных элементов массива.
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Среди 15 действительных чисел, введеных с клавиатуры, подсчитать количество элементов, равных последнему, и выдать их номера на экран
Ответы (1)
Дан массив MAS вещественного типа, содержащий 20 положительных и отрицательных элементов. Сформировать массив С из положительных элементов массива MAS, имеющих четный индекс. Найти сумму квадратов элементов нового массива.
Ответы (1)