Задать вопрос
31 июля, 14:26

1. Массив из 10 элементов, вводим их с клавиатуры. Вывести на экран все положительные элементы и вычислить их сумму

2. Вывести на экран элементы массива, стоящие на нечетных местах, вычислить их сумму (В массиве 20 элементов, заполнен случайными числами.)

3. Массив из 20 элементов, заполнен случайными числами в диапазоне от - 50 до 50. Вывести на экран, посчитать количество чисел, меньших 25

+5
Ответы (1)
  1. 31 июля, 17:12
    0
    1

    var

    a:array[1 ... 10]of integer;

    s, i:integer;

    begin

    for i:=1 to 10 do readln (a[i]) ;

    for i:=1 to 10 do

    if a[i]>0 then

    begin

    s:=s+a[i];

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('Сумма: ', s) ;

    end.

    2

    var

    a:array[1 ... 20]of integer;

    s, i:integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 20 do

    begin

    a[i]:=random (20) ;

    write (a[i],' ') ;

    end;

    writeln;

    write ('Искомые элементы: ') ;

    for i:=1 to 20 do

    if i mod 2=1 then

    begin

    s:=s+a[i];

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('Их сумма: ', s) ;

    end.

    3

    var

    a:array[1 ... 20]of integer;

    s, i:integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 20 do

    begin

    a[i]:=random (-50,50) ;

    write (a[i],' ') ;

    end;

    writeln;

    write ('Меньше 25: ') ;

    for i:=1 to 20 do

    if a[i]<25 then

    begin

    s:=s+1;

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('Их количество: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Массив из 10 элементов, вводим их с клавиатуры. Вывести на экран все положительные элементы и вычислить их сумму 2. Вывести на экран ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Задать массив m (7) случайными числами от 12 до 73. Утроить элементы массива, стоящие на нечетных местах. Утроить чётные элементы массива, стоящие на нечетных местах
Ответы (2)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)