Задать вопрос
16 июня, 16:05

Найти

НОД (M, N, K) - наибольший

общий делитель трех чисел: M,

N и K. Числа M, N

и K хранятся в первой строке входного

файла Evclid. in, а НОД этих чисел

сохранить в выходном файле Evclid. out.

+5
Ответы (1)
  1. 16 июня, 16:21
    0
    Program nod1;

    const InFile = 'Evclid. in';

    OutFile = 'Evclid. out';

    var m, n, k, nod, i, max: integer;

    begin

    assign (input, infile) ;

    reset (InPut) ;

    Read (InPut, m) ; Read (InPut, n) ; Read (InPut, K) ;

    Close (inPut) ;

    nod: = 1;

    if m > = n then

    max: = m

    else max: = n;

    if k > max then

    max: = k;

    for i: = 1 to max do

    if (m mod i = 0) and (n mod i = 0) and (k mod i = 0) and (i > nod) then

    nod: = i;

    assign (OutPut, OutFile) ;

    ReWrite (OutPut) ;

    Write (OutPut, nod) ;

    Close (output) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти НОД (M, N, K) - наибольший общий делитель трех чисел: M, N и K. Числа M, N и K хранятся в первой строке входного файла Evclid. in, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)
Написать программу для сложения А и В в троичной системе счисления. Числа А и В хранятся в первой строке входного файла Exemp. in их сумма в троичной системе-в выходном файле Exemp5. out
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Формат входного и выходного файла На первой строке входного файла находятся два целых числа a и b (-109 ≤ a, b ≤ 109 ). Вашей программе требуется вывести единственное число - сумму заданных чисел a + b.
Ответы (1)
Заданное число M из диапазона 0 ... 109. перевести в троичную систему счисления. Число M хранится в входном файле Exch. in, его представление в троичной системе счисления сохранить в выходном файле Exch. out.
Ответы (1)